Системные требования CS-Cart

Система CS-Cart может работать как на виртуальном хостинге, так и на выделенном сервере. Обязательные условия, которые должен иметь хостинг или выделенный сервер для нормальной работы CMS CS-Cart, это:

  • PHP версия с 5.1 до 5.3 (PHP 5.4 пока не поддерживаются);
  • MySQL версии 4.1 или выше.

Эти требования делают CS-Cart совместимым с большинством web-серверов, которые поддерживают PHP и MySQl. Тем не менее, официально рекомендуется использовать web-сервер Apache, как надежный и стабильный сервер для онлайн-магазина.

Требования и рекомендации

  • safe_mod - отключен;
  • GD library - установлено;
  • cURL support - активировано;

Данное расширение необходимо для безопасного соединения с некоторыми платежными системами, в том числе: WebMoney, Robokassa, PayPal и другие. Также cURL support используется для расчета стоимости доставки в режиме реального времени.

  • file_uploads - включен;
  • Файл: ".htaccess", должен иметь следующие директивы: DirectoryIndex, Deny, Allow, Options, Order, AddHandler, RewriteEngine, RewriteBase, RewriteCond and RewriteRule.

Операционная система web-сервера

Относительно ОС web-сервера, официально рекомендуется использовать  Unix-подобные, такие как: FreeBSD или Linux, что касается Windows, на данный момент поддержка не осуществляется. Рекомендуется использовать Unix-подобные системы из соображений организации более высокого уровня безопасности.

Хостинг-провайдер

На данный момент, существуют сотни тысяч хостинг-провайдеров, которые могут обеспечить все необходимые условия для нормальной работы интернет-магазина на CS-Cart. Если вы все еще не определились с хостингом для сайта, тогда мы рекомендуем ознакомиться со специализированными провайдерами, работающими с CS-Cart.